B A C K U P H A W K

Yes, SaasLand is compatible with WordPress 5.0 and higher versions.